Antville Project

Language

I'm having trouble with the text font for the log.
I'm trying to use thai font which is my language with the log and I have changed the font type in my preference both for title and for text and the title font shows thai characters just fine.

The text part is all messed up. I just don't know why the title font works and still the text won't. Please help.

comment    

 
hns, September 14, 2001 at 12:05:53 PM CEST

Thanks for the report! We don't have the computers to test different locales, so this kind of feedback is very valuable to us. It looks like there's a problem in one of our text encoding functions. I'll try to fix that today.

link  


... comment
 
hns, September 14, 2001 at 2:42:58 PM CEST

Asaya, I've made some changes to the text encoding function. Can you please tell us if it works better for Thai characters now?

Ooops, no, I just see that it still doesn't work. Sorry, will try some more.

link  


... comment
 
asaya, September 14, 2001 at 4:42:16 PM CEST

I can's access the log I created yesterday anymore, it just keeps showing the main page www.antville.org but the url on the browser is my log rrl asaya.antville.org. So I tried to re-create the log but it won't allow me to use the name "asaya" as my log name anymore so I just chose another one, BLAH.

I can access the BLAH log just fine but the characters are still pretty much the same.

I noticed that when I try to access my log, I'll need to log in first, then when I logged in, it would re-direct me to the main page of antville. Now there's a link there for my page as the recent updated log I just wondering what if my log is not on the recent update list, how can I access my log as a logged in member?

Sorry, I'm all new to this and I have soo many questions.

thanks!

link  

 
hns, September 14, 2001 at 6:25:18 PM CEST

I think it should be working now

Don't worry about asking questions and reporting problems. You're helping us improve this application.

Sometimes you get redirected to the wrong page after logging in. We know about this problem, it's a bug in third-party software we use and it'll eventually go away when we upgrade.

Having a list of all the weblogs one owns (or is a member of) on the antville main page is definitely a good idea.

PS: just a curiosity question: how did you find us?

link  

 
robert, September 14, 2001 at 10:45:18 PM CEST

hey great!

thanks for that, hannes. regarding redirection: i'm not sure if ther's not a bug in the antville-code. i'll go through it when i'm back in barcelona.

link  

 
hns, September 15, 2001 at 12:03:27 PM CEST

Actually the only thing I did in this regard was to disable character entity encoding in Helma's format() and encode() functions. Basically, the Helma snapshot which is running on antville.org doesn't suppose it understands what kind of characters it's actually dealing with - it actually thinks it is Western encoded text looking somewhat like "ÂÒÂÒÁ¡Ñ¹", but it leaves it alone. This works well, because western browsers expect western (ISO-8859-1) encoding (which is also the default encoding for HTTP) and usually character entity references like ö are not needed anymore (they were back when Mac browsers expected a Macintosh encoding).

So what I'm saying is that this is just a quick fix until we solve the actual problems: storing international text (which means replacing MySQL) and reading international text from HTTP requests. The latter requires a bit of guesswork, because most browsers don't tell which encoding they are using for form data. The solution is most likely to set a character encoding per weblog and not only use it for output encoding, but also presume it when parsing form data for that weblog. I think that browsers do send form data in the same encoding the page containing the form is in so this could work well, but I have to make some more tests to see if I'm right.

link  


... comment
 
asaya, September 14, 2001 at 6:53:12 PM CEST

It's working!!!!!!!!!!!!!!!!!!!

This is great!!!!!!!!! Millions thanks!!!

I still can't access my first weblog "asaya", though.

About how I found this site : I actually don't remmember the exact URL but I followed a link from somebody's page. I was trying to find a weblog service that let readers post freely, not just in the comment system and ..wow!!. They can even register to be MY MEMBER!! that's so great!

thanks

link  

 
hns, September 14, 2001 at 10:33:15 PM CEST

you're welcome

just remember that this is a test site, and we're still trying things out so not everything's working as it should.

link  


... comment


The Antville Server Fund has been a great success. Thanks to everybody who contributed!
online for 7387 Days
last updated: 1/4/11, 10:22 AM
status
Youre not logged in ... Login
menu
September 2021
SunMonTueWedThuFriSat
1234
567891011
12131415161718
19202122232425
2627282930
July
recent
zfuture's house here is zfuture's
house
by zfuture (7/31/03, 2:59 AM)
i understand your concerns however,
i hardly can think of a solution. certainly, if the...
by tobi (7/29/03, 9:47 AM)
Found several more similar sites
listed This is getting to be quite a concern to...
by cobalt123 (7/27/03, 7:56 PM)
Second Post Alert on Referrer
bug livecatz I put this into "help" and now here:...
by cobalt123 (7/26/03, 7:14 PM)
well it's not easy to
find from here, anyway. think we should include a link,...
by tobi (7/24/03, 11:25 AM)
So finally I found
the helma Bugzilla - stupid me.
by mdornseif (7/24/03, 10:28 AM)
clock not that it's particularly
earthshattering but the antclock is running slow by about 15...
by kohlehydrat (7/23/03, 8:25 PM)
but blogosphere.us isn't can't really
be rated as spam can it?
by kohlehydrat (7/23/03, 8:08 PM)
More referrer spam www.webfrost.com
by Irene (7/23/03, 7:55 PM)
How to log skin names
I accessed to console?? Hi, I would like to know...
by winson (7/23/03, 4:12 PM)

Click here to get an XML version of this weblog.

Made with Antville
powered by
Helma Object Publisher